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1. DOCUMENT COPYRIGHT 

2015 © Enviroware srl 

All rights reserved. No parts of this document may be reproduced in any form or by any 

means - graphic, electronic, or mechanical, including photocopying, recording, taping, or 

information storage and retrieval systems - without the written permission of Enviroware. 

Products that are referred to in this help may be either trademarks and/or registered 

trademarks of the respective owners. Enviroware makes no claim to these trademarks. 

While every precaution has been taken in the preparation of this document, Enviroware 

assumes no responsibility for errors or omissions, or for damages resulting from the use 

of information contained in this document or from the use of programs and source code 

that may accompany it. In no event shall Enviroware be liable for any loss of profit or any 

other commercial damage caused or alleged to have been caused directly or indirectly 

by this document. 

 

Printed: 2015-05-04 
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2. INTRODUCTION 

WindRose PRO is a Windows application for representing directional variables starting 

from raw data or from their frequencies. 

It can be used to represent wind roses, but it is also possible to represent roses of any 

other variable of interest. A wind rose is a chart which gives a view of how wind speed 

and wind direction are distributed at a particular location over a specific period of time. It 

is a very useful representation because a large quantity of data can be summarised in a 

single plot. 

 

WindRose PRO is capable to load different file formats: 

 Microsoft Excel files (XLS and XLSX) 

 ASCII files with fields separated by specific symbols 

 EnergyPlus Weather files 

 Typical Meteorological Year (TM2 and TM3) 

 Compressed WBAN hourly surface observations (TD-1440) 

 CALMET 5.8 surface file 

 CALMET 6 surface file 

 AERMOD surface files 

 ISC3ST files 

 Integrated Surface Hourly (NOAA ISH) 

 NMEA0183 files 

 Frequencies 

 

Date/time filtering options according to year, month, day of the week, hour of the day or 

day/night hours can be activated. 

 

Beside the classical wind roses, other plots can be generated: the rose of 

minimum/average/maximum values, raw data and rays. Raw data plot allows to represent 

a third variable when data are loaded as Microsoft Excel files. 

 

http://www.enviroware.com/
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WindRose PRO allows the wind roses to be exported in DXF format for CAD systems, in 

SHP format for GIS environments and in KML format for Google Earth. Windroses can 

also be copied or saved in many raster formats (JPG, PNG, etc.). 

 

Numerical results can be exported in Microsoft Excel format, and charts are automatically 

created within such files. 

 

Wind turbines power curves can be imported in WindRose PRO (or directly defined in it) 

and used to define the wind power potential of a specific location. 

 

A batch processing procedure allows the automatic creation of hourly, three-hourly and 

monthly wind roses starting from a single input file. 

 

Other features of the software are: 

 Typical day is calculated when date and time are loaded 

 Calculates the theoretical wind power distribution 

 Calculates crosswind, headwind and tailwind, and evaluates the correct orientation 

of a runway 

 Calculates the exceeding frequencies 

 Calculates the wind erosion emission factors for PM30, PM15, PM10 and PM2.5 

 Automatically produces a text summary of the data 

 User’s logo can be added on the plot 

http://www.enviroware.com/
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3. SYSTEM REQUIREMENTS 

WindRose PRO is a Windows application that can be used both on 32 bit and 64 

platforms. It is based on the .NET framework 4, which must be present on the PCs where 

it is installed (the installation package checks if they are present). WindRose PRO has 

been tested by the developers under Windows XP, Windows Vista and Windows 7. It has 

not been tested under older versions of Windows. 

It might not function correctly under any Windows emulator of Mac, Linux or Unix systems. 

3.1 Installation 

To install WindRose PRO from the distribution setup package, simply double click over 

the setup file. The Setup program will issue a number of prompts. Unless you have a 

reason to override the defaults it is strongly recommended that you accept the installation 

default settings (just press OK, Yes, or Next, as appropriate). WindRose PRO requires 

the .NET framework 4, and the installation package checks for their presence. If they are 

not present, the setup package will automatically install them on your PC. The Microsoft 

C++ redistributable will be also installed if needed. 

3.2 Uninstallation 

There are two ways to uninstall WindRose PRO, should you wish to do so. 

3.2.1 Control Panel 

Activate the Control Panel, double click Add/Remove Programs, and double click on the 

WindRose PRO list box entry. 

3.2.2 Start Menu 

From the Start menu, click Programs, then WindRose PRO, and then Uninstall WindRose 

PRO. 

http://www.enviroware.com/
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4. WINDROSE PRO ORDERING INFORMATION 

All orders are subject to the WindRose PRO License agreement. Enviroware srl is 

willing to license the WindRose PRO software only if you accept all of the terms in the 

license agreement. Please read the terms carefully before you install the software, 

because by installing the software you are agreeing to be bound by the terms of the 

agreement. If you do not agree to the terms, Enviroware srl will not license the WindRose 

PRO software to you, and in that case you should immediately delete all copies of the 

software you have in any form. 

4.1 Permanent Software Key Delivery 

The permanent software key will be sent by email in no more than 2 working days after 

the purchase. If the order is received during working days from 9 a.m to 6 p.m Italian time, 

the permanent software key is typically sent in less than one hour. 

4.2 Credit Card Orders 

You can place secure credit card orders on the Internet using the order link on the 

Enviroware web site (http://www.enviroware.com/portfolio/windrose-pro3/). 

Alternatively, you can use the BUY NOW link on the License Registration form  which 

automatically transmit your computer identification code needed to generate your license. 

 

http://www.enviroware.com/
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4.3 Other types of Orders 

Please contact Enviroware srl (info@enviroware.com) to know about the possibility of 

other order types. 

4.4 WindRose PRO Pricing 

Current price is indicated on the WindRose PRO web page: 

http://www.enviroware.com/portfolio/windrose-pro3/. 

The software purchase price includes: 

 the software package and the unlimited-time license; 

 one year of free software updates; 

 one year of free technical assistance. 

After the first year software updates, technical assistance and license transfer will be 

available only to the users which will purchase the yearly, or multi year, maintenance 

plan. 

http://www.enviroware.com/
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5. REGISTRATION 

WindRose PRO must be activated with an evaluation key or with a permanent key. 

5.1 Evaluation key 

If you want to evaluate WindRose PRO click on the TRY NOW link on the License 

Registration form  represented in the following figure (you need an active internet 

connection during this phase). 

 

A web page of the Enviroware's internet site will appear, asking to insert optional 

information (country and town) which will be used only for statistical purposes. You may 

insert your email address if you want to be informed about new Enviroware products, 

otherwise click the Proceed button and you will see a page containing an evaluation 

license key. Copy the key, paste it in the License key field shown in the previous figure, 

then click the registration button  at the lower right corner of the form. At this point you 

will be able to evaluate WindRose PRO for a limited number of days. 

http://www.enviroware.com/
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The evaluation version has some limitations with respect to the full one: 

 watermarks or notes are written on each plot, 

 images cannot be copied, 

 images cannot be saved, 

 check for updates does not work. 

5.2 Permanent key 

You obtain a permanent key only after purchasing WindRose PRO. The permanent key 

is bound to a single computer by means of the computer identifier that you must write 

exactly during the payment procedure (if you use the BUY NOW link shown on the previous 

image, the computer identifier is automatically communicated to the internet site for the 

payment). The computer identifier is a code automatically generated by the software to 

uniquely identify the PC where it is installed. 

After receiving the payment we will send to the buyer: 

 an email containing the instructions to download the full version of the software 

and the permanent license; 

 an email containing the invoice in PDF format. 

 

Please note that: 

 the software is not physically delivered on any type of support, it will be 

downloaded from an internet address; 

 the permanent license alone will not enable all the features of the software, the 

buyer must download and install the full version of the software. 

 

http://www.enviroware.com/
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6. SUPPORT, QUESTIONS AND WARRANTY 

To check whether you have the most recent version of WindRose PRO, please use the 

Check for Updates menu item. 

Please see the WindRose PRO web page 

(http://www.enviroware.com/portfolio/windrose-pro3/) for answers to common questions. 

The best way to report problems is to send an email to info@enviroware.com (you can 

also use the feedback button on the software, which is represented by an envelope). 

When reporting problems, please include at least the following information: 

1. Is the problem reproducible? If so, how? (Please include the input data). 

2. What version of Windows are you using? 

3. What version of WindRose PRO are you running? (To see what version of 

WindRose PRO you have, choose the About button). Please include version number and 

date in your problem report. 

4. If a dialogue box with an error message was displayed, please include the full text 

of the dialogue box, including the text in the title bar. 

6.1 Technical warranty 

WindRose PRO is covered by a technical warranty for a period of 6 (six) months after the 

purchase date. During this period Enviroware will fix all the bugs that should arise. 

 

http://www.enviroware.com/
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7. TUTORIAL 

7.1 Menu and buttons 

The main form of the WindRose PRO software is represented in the next figure. 

 

There are four menu topics: 

 File: allows to save a new configuration file (i.e. a set of options used for representing 

the directional data) and to load an existing configuration file. 

 Options: allows to specify all the options that will be used for representing the 

directional data: data intervals, plot title, user's logo, legend, calms, plot types, plot 

scale, percentage circles, runways calculation, filtering of data according to their 

values or to date/time, wind power options and others. 
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 Actions: used to load the directional data, to analyse them, to draw the plot, export, 

save, print or copy it, view the charts, and to insert wind turbine features. 

 Help: allows to access the User’s Guide (this document), to send feedbacks and to 

carry out other operations. 

The main operations can also be done by means of the buttons placed within the toolstrip 

just below the main menu, as represented in the previous figure. 

7.2 File 

7.2.1 File > Load configuration 

The File > Load configuration menu item allows to load WindRose PRO 

configuration files previously saved. The same result is obtained by clicking the button 

shown in the next figure. The configuration files are XML files with the extension .wro3. 

 

7.2.2 File > Save configuration 

The File > Save configuration menu item allows to save WindRose PRO 

configuration files. The same result is obtained by clicking the button indicated in the next 

figure. 
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7.2.3 File > Load data 

The Actions > Load data menu item allows to look for an input file of directional data 

within the user's PC. The same result is obtained by clicking the button shown in the next 

figure.  

 

Some input files are distributed with the WindRose PRO setup package (see next figure 

for example), and are located within the sample folder. The WindRose PRO sample folder 

is \Enviroware\WINDROSEPRO\ under the common application data folder, which 

depends on the Windows version installed on the user's PC. For example, in Windows 7 

the common application data folder is C:\ProgramData\, while in Windows XP it is in 

C:\Documents and Settings\All Users\Application data\. 

 

The data can be loaded in two forms: as data organised in records or as frequencies. 

When data are loaded as frequencies, not all the analyses can be carried out (for example 

it will be not possible to plot roses of average speeds, or of maximum speeds). 

IMPORTANT: For real numbers the decimal separator must be a dot (.), not a 

comma (,). If this is not the case, WindRose PRO will not work correctly. 

 

When data are organised in records, they can be loaded as ASCII files with fields 

separated by tabs, commas, semicolon or spaces, as Microsoft Excel files, as AERMOD 

surface meteorological file, as ISC3ST meteorological file, as EnergyPlus Weather files, 

and others. 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

17 

 

Wind direction must always be in degrees (do not use radians), while the units of the 

directional variable are not important for the software (wind speed for example can be in 

m/s or in knots). After loading the data, the file name, the total number of data and the 

total number of valid data, appear at the bottom of the main software mask. The number 

of valid data is determined using the information that the user inserts in the value filtering 

mask. 

7.2.3.1 Microsoft Excel files (*.XLS and *.XLSX) 

The data organised in records can be read from Microsoft Excel files, both Excel 97-2003 

(*.XLS) and Excel 2010 (*.XLSX). The file must have a sheet containing, at least, 

directions and corresponding values in two different columns. Each column must have a 

header record. The user first selects the worksheet containing the data, then the columns 

containing the direction and the directional data (for example wind speed). 

The user may also select a column containing date and time of each measurement. This 

feature allows to filter the data to be analysed according to year, month, hour of the day, 

or day/night hours. Moreover WindRose PRO will automatically calculate the typical day 

(i.e. the average of the variable for each hour of the day). 

Since dates are written in different formats around the World, the user must also select 

the date/time format of the Excel file. The possible formats are: 

 DD/MM/YYYY hh:mm:ss 

 MM/DD/YYYY hh:mm:ss 

 YYYY/MM/DD hh:mm:ss 

 YYYYMMDDhhmmss 

Minutes (mm) and seconds (ss) are not mandatory. This means that you will select 

DD/MM/YYYY hh:mm:ss even if your dates are in the format DD/MM/YYYY hh. 

The user may also select a column containing a third variable (e.g. pollutant 

concentration, temperature, etc.) which might be used to generate the raw data plot. 

The user may also specify the action to carry out when cells with non-numerical values 

(for example empty cells) are found. The two possible options are to stop reading the 

Excel file with an error message, or to substitute non numerical values with a specified 

value. In this last case, the same value is used for direction, data and third variable, if 
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used. Be aware that the value used for substitutions must not alter your data. For 

example, if you filter values smaller than 0, use a negative value for substitutions. 

Note that Microsoft Excel must be installed on the user's PC. 

Examples of Microsoft Excel input files (both XLS and XLSX) are contained in the sample 

directory. 

 

The worksheet with the data is expected to be in a table-like format with column 

headings in the first row and rows of data beneath. 
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If you see the warning message “Some headers cells in the selected Excel worksheet 

have no titles”, the software is unable to find a title to put in the drop down boxes in order 

to allow to select the variables. It is a warning message, therefore you can continue to 

load the data. However, if you don't like such messages try one of these solutions: 

1) Verify if all the columns with the data in your file have a title, if not add one or more 

titles as needed. 

2) Excel has a sort of memory of the cells that were filled in. If you simply delete the 

contents of some columns they still appear as used, and WindRose PRO3 tries to 

load them. Since they do not have a title, the warning message is issued. The 

solution is to select the whole columns (clicking on the letters identifying the 

columns) and delete them. It is important to delete the columns, not only their 

contents. 

 

If you get a message after loading your data saying that N substitutions have been done 

for empty cells, the reason may be similar to point 2 above. Select the whole rows at the 

bottom of your data and delete them. 

 

Another issue concerns the date format. If the columns containing dates are actually 

formatted exactly as dates in Excel the selection between the two formats “DD/MM/YYYY 

hh:mm:ss” or “MM/DD/YYYY hh:mm:ss” works without problems. Sometimes dates in 

Excel appear as “DD/MM/YYYY hh:mm:ss” even if they are not formatted as dates, but 

as “Custom”. In these cases, if the user specifies the format that seems correct 

(“DD/MM/YYYY hh:mm:ss”) WindRose PRO3 gives an error because the day and month 

fields are misplaced. The solution in these situations is to specify the “MM/DD/YYYY 

hh:mm:ss” even if it is not the format seen within the Excel cells. 

 

Finally, charts must be at the end of the worksheets. If the first worksheet is a chart the 

software gives an error message. 
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7.2.3.2 AERMOD surface meteorological file 

AERMOD is an atmospheric dispersion model belonging to the list of the US-EPA 

preferred/recommended models. In order to carry out a simulation AERMOD needs a 

surface meteorological file and an upper air meteorological file, both containing variables 

for each hour of the simulation. WindRose PRO reads directly the AERMOD surface 

meteorological file, which must have a SFC extension. 

The default directional variable is wind speed, but the user may choose other variables 

contained in the surface meteorological file. 

 

Date and time within the AERMOD surface file are also read by the software. It is then 

possible to filter the data to be analysed according to year, month, hour of the day, or 

day/night hours. Moreover WindRose PRO automatically calculates the typical day (i.e. 

the average of the variable for each hour of the day). 

An example of AERMOD surface meteorological file is contained in the sample directory. 

7.2.3.3 ISC3 Short Term meteorological file 

ISC3ST (Industrial Source Complex Short Term, version 3) is an atmospheric dispersion 

model belonging to the list of the US-EPA alternative models. In order to carry out a 

simulation ISC3ST needs a meteorological file containing variables measured at surface 

for each hour of the simulation. WindRose PRO reads directly the ISC3ST meteorological 

file, which must have a MET or ISC extension. 

The default directional variable is wind speed, but the user may choose other variables 

contained in the meteorological file. The user must also specify the file format between 

FREE or CARD, which are the two ASCII formats recognised by ISC3ST. Finally, since 

ISC3ST uses flow vector, which is the direction toward which the wind is blowing, 

therefore the opposite of wind direction, the user might want to rotate it by 180 degrees 

before analysing the data and creating the wind rose. Be aware that the rotation is stored 
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as an option, and the user must deselect it when other data, for example from an 

AERMOD file, are loaded. 

 

Date and time within the ISC3ST meteorological file are also read by the software. It is 

then possible to filter the data to be analysed according to year, month, hour of the day, 

or day/night hours. Moreover WindRose PRO automatically calculates the typical day (i.e. 

the average of the variable for each hour of the day). 

An example of ISC3ST surface meteorological file is contained in the sample directory. 

7.2.3.4 CALMET 5.8 and CALMET 6 surface file 

CALMET is the diagnostic meteorological model of the CALPUFF modelling system,  

belonging to the list of the US-EPA preferred/recommended models. The meteorological 

information needed in input by CALMET is contained in a surface file with the hourly  

observations of different stations, and in one or more vertical soundings. WindRose PRO 

reads the surface meteorological file of CALMET 5.8 (which is the current regulatory 

version) and CALMET 6. It will not work with CALMET versions having a surface file 

format different from the formats of version 5.8 or version 6. The CALMET file extension 

must be *.DAT (for example SURF.DAT). 

Once the user has selected a CALMET file, the mask represented in the following figure 

appears. In the upper part of the mask the surface file header records are summarised. 

Since a surface file typically contains the observations of more stations, the user must 

select the station to analyse. The default directional variable is wind speed, but the user 

may also select opaque sky cover, air temperature, relative humidity and atmospheric 

pressure. 
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7.2.3.5 Delimited ASCII file 

The generic ASCII file has been designed to allow the user to load data which may have 

a variety of formats. These files may have ASC, VEC, TXT or CSV extension. The data 

are loaded in two phases: first the user specifies the file format choosing some possible 

options, then selects the variables to analyse. Data in this format are organised in records, 

each one containing fields separated with a specified separator. At least one header 

record containing variable names is mandatory. 

The user may specify: 

 The field separator, which can be tab, comma, semicolon or space. 

 If a second header record is present, for example with the measurements units of 

the corresponding variables. In this case both the header records are used to 

create the column names. 

 If date and time are present within the file and must be used. 

 If date and time are in the same field or if they are in two separate fields (when the 

field separator is the space, date and time can only be in two separate fields). 

 The year month day separator between dash (-), slash (\) or backslash (/). 

 The hour minute separator between colon (:) or dot (.). 

 The date format between YYYY MM DD or DD MM YYYY or MM DD YYYY. 

 The hour counting format between 00-23 and 01-24. 
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After the above options have been specified, click the  button to continue, and select 

the variables to analyse in the lower part of the mask. 

Date and time, if the user specifies to use them, are also read by the software. It is then 

possible to filter the data to be analysed according to year, month, hour of the day, or 

day/night hours. Moreover WindRose PRO automatically calculates the typical day (i.e. 

the average of the variable for each hour of the day). 
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Examples of ASCII file are contained in the sample directory (sample.csv,   

generic_sample.vec and sample.asc). The file sample.csv has only two fields (direction 

and speed) separated by a comma, date and time are not present within the file. The file 

sample.asc is identical to sample.csv, the only difference is that fields are separated by 

spaces. In the contrary, in order to load the generic_sample.vec file, the user must select: 

 Use date and time 

 Date and time in two distinct fields 

 Year month day separator: backslash (/) 

 Hour minute separator (:) 

 Date format: DD MM YYYY 

 Hours: 00-23 

 Header records: 2 

 Fields separator: Tab 

7.2.3.6 Compressed WBAN Hourly Surface Observations (TD-1440) 

Another file format which WindRose PRO can read is the compressed WBAN hourly 

surface observations (TD-1440). These data are distributed by the US-EPA as zipped 

files containing years from 1984 to 1992 for many US locations. The TD-1440 files are 

used by the ARMOD meteorological processor (AERMET) and by other meteorological 

processors. Such files can be downloaded from the US-EPA internet site 

(http://www.epa.gov/ttn/scram/surfacemetdata.htm).  
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7.2.3.7 EnergyPlus Weather (EPW) 

EnergyPlus (http://apps1.eere.energy.gov/buildings/energyplus/) is an energy simulation 

software which models heating, cooling, lighting, ventilating, and other energy flows as 

well as water in buildings. 

EnergyPlus has its own weather file format which can be read from WindRose PRO. 

EnergyPlus weather files (*.EPW) are available for hundreds of points around the world, 

and can be downloaded from the US Department of Energy website. 

WindRose PRO allows to apply date and time filtering on the wind speed and direction 

loaded from the EnergyPlus Weather data. Since the year of data can vary arbitrarily for 

each month within the EPW data, filtering on years is not allowed. 

7.2.3.8 Typical Meteorological Year (TMY2) 

A Typical Meteorological Year (TMY) is a data set of hourly values of solar radiation and 

meteorological elements for a one-year period. It consists of months selected from 

individual years and concatenated to form a complete year. The intended use of the TMY 

data is for computer simulations of solar energy conversion systems and building 

systems. Because of the selection criteria, TMYs are not appropriate for simulations of 

wind energy conversion systems, nor for atmospheric dispersion simulations. 

A TMY provides a standard for hourly data for solar radiation and other meteorological 

elements that permit performance comparisons of system types and configurations for 

one or more locations. A TMY represents conditions judged to be typical over a long 

period of time, such as 30 years. Because they represent typical rather than extreme 

conditions, they are not suited for designing systems and their components to meet the 

worst-case conditions occurring at a location.  

The original TMY data were derived for the period 1952-1975. The TMY2 data refer to 

the period 1961-1990, and have been derived from the 1961-1990 National Solar 

Radiation Data Base (NSRDB). WindRose PRO reads the TMY2 data, which can be 

obtained from this link: http://rredc.nrel.gov/solar/old_data/nsrdb/1961-1990/tmy2/ The 

file extension of the TMY2 files is TM2. Once loaded a TMY2 file the following mask 
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appears. The upper part summarises the header records. The default directional variable 

is wind speed, but other variables can be selected if needed. 

The TMY2 data are available for 239 locations in the USA. 

 

7.2.3.9 Typical Meteorological Year (TMY3) 

The TMY3 data are the most recent version of the Typical Meteorological Year. 

Compared with the TMY2, they are based on more recent and accurate data, and extend 

up to 2005. The TMY3 data are available for 1020 locations in the USA and can be 

downloaded from http://rredc.nrel.gov/solar/old_data/nsrdb/1991-2005/tmy3/. 

The file extension of the TMY3 files is CSV. Once loaded a TMY3 file the following mask 

appears. The upper part summarises the header records. The default directional variable 

is wind speed, but other variables can be selected if needed. 

http://www.enviroware.com/
http://rredc.nrel.gov/solar/old_data/nsrdb/1991-2005/tmy3/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

27 

 

 

7.2.3.10 NOAA Integrated Surface Hourly 

The NOAA database ISH (Integrated Surface Hourly), or ISD (Integrated Surface Data), 

collects all of the NCDC and Navy surface hourly data (TD3280), NCDC hourly 

precipitation data (TD3240), and Air Force Datsav3 surface hourly data (TD9956), into 

one global database. The database totals 

approximately 350 gigabytes, for nearly 20000 stations, with data from as early as 1900 

to present. The building of the database involved extensive research, data format 

conversions, time-ofobservation conversions, and development of extensive metadata to 

drive the processing and merging. Additional information about the ISH database can be 

found in http://www1.ncdc.noaa.gov/pub/data/noaa/ish-tech-report.pdf  

The ISH data can be downloaded from http://www1.ncdc.noaa.gov/pub/data/noaa/  

In order to be read by WindRose PRO, these files must have extension ISH or ISD 

(typically they do not have any extension, therefore it must be added by the user). The 

current version of the software reads only the non variable part of each record of data 

(i.e. the first 105 characters). Once the file has been read its content is automatically 

shown within a text editor, while wind directions, wind speeds, dates and times are stored 

in order to produce the wind rose. Dates and time are stored only if the year is valid, which 

means not equal to 9999. 
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An example of variables extracted from one ISH file and summarised in a text editor is 

shown in the next figure. 

 

The first record is a header, while all the other records contain the data. The meaning of 

each column is explained in the following table (note that the order of the variables is 

important because some columns have the same header). For a detailed explanation 

about the meaning of the quality codes, missing values and other important information 

the user must read http://www1.ncdc.noaa.gov/pub/data/noaa/ish-format-document.pdf. 

 

Date/time Is the date and time of the record of data. Its format is YYYY-MM-DDThh:mm. Note that 
YYYY=9999 means invalid date/time. 

USAF Fixed weather station USAF master station identifier. 

WBAN Fixed weather station NCDC WBAN identifier. 

Lat Latitude coordinate of the point of observation (degrees). 

Lon Longitude coordinate of the point of observation (degrees). 

RepTp Report type: the code that denotes the type of geophysical surface observation. 

Elev Elevation of the point of observation (m) relative to mean sea level. 

WD Wind direction (degrees). 

Q Wind direction quality code. 

T Wind observation type code 

WS Wind speed (m/s) 

Q Wind speed quality code. 

CeilH Ceiling height (m) 

Q Ceiling height quality code 

D Ceiling height determination code 
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O CAVOK (Ceiling and Visibility OK) code 

Vis Visibility distance (m) 

Q Visibility distance quality code 

V Visibility variability 

C Visibility variability quality code 

TC Air temperature (°C) 

Q Air temperature quality code 

TD Dew point temperature (°C) 

Q Dew point temperature quality code 

Prs Atmospheric pressure relative to mean sea level (hPa) 

Q Atmospheric pressure quality code 

7.2.3.11 Frequencies (FRQ) 

The frequencies data consist of ND+1 records, the first one is composed by a single field 

and the other ones are composed by NS fields, where ND is the number of directions in 

the wind rose and NS is the number of speed classes. The first record contains the 

number of calms (put 0 if you have no calms), while the other ones contain the number 

of events in each directions. The first direction is always North, and the others follow 

clockwise. 

Be aware that: 

1. you must first set the directions and the number of intervals, then load the 

frequencies data according to the specified values of ND and NS; 

2. the numbers are integers indicating the number of events, not percentages. 

Frequencies input file must have the extension .FRQ. 

An example of frequencies data for 16 directions and 4 wind speed classes is shown 

below. 

1036 

1565,2097,627,93 

2263,1247,136,8 

1803,171,0,0 

1433,60,0,0 

3152,317,8,0 
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601,69,0,0 

429,26,0,0 

567,51,0,0 

3626,651,34,0 

2620,1061,68,0 

1566,726,77,0 

385,128,8,0 

650,349,50,8 

898,662,169,93 

 

An example of frequencies input file is contained in the sample directory and is called 

sample.frq. Note that in order to use such sample file, you first need to load the 

corresponding options file named frq_default.wro. 

7.2.4 File > Exit 

Exits the program. The same effect is obtained by using the rightmost button placed on 

the toolstrip just below the main menu. 

 

7.3 Options 

7.3.1 Options > Intervals 

The Options > Intervals menu item allows to specify the data intervals to show 

within the chart. The intervals form can also be loaded by means of the button shown in 

the next figure. 

 

The intervals allow to specify how data must be grouped for their graphical representation. 

For each interval, an initial and a final values must be indicated, together with its colour 
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and, optionally, its caption. If the caption is not specified, it is determined using the initial 

and final values of the interval. Each interval can be inserted or modified by inserting the 

corresponding values within the text boxes and clicking the  button. A single level can 

be deleted by selecting it within the grid and clicking the  button, while the  button 

deletes all the levels within the grid. 

Once the intervals have been inserted, they can be saved in a CSV file by means of the 

 button, and then reloaded when needed by means of the  button. Examples of 

CSV interval files are distributed with the software. Intervals are usually defined by the 

data greater than the initial value and smaller or equal to the final value, however this 

definition can be inverted by means of the  button.  

Before loading data as frequencies (files with FRQ extension) the number of intervals 

specified in this mask, and the number of directions, must be equal to the directions and 

intervals of the frequencies table, otherwise the software shows an error message. 

The Auto checkbox allows to create captions automatically while the user inserts the 

levels. Captions are created as “IV – FV”, where IV is the initial value and FV is the final 

value. 

This form also allows to specify a background colour for the plot (default is white), and to 

specify the outline colour and width between each interval. 
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As in all the masks of WindRose PRO, the  button exits without saving the options (or 

doing anything), while the  saves the options (or does an action), then exits. 

7.3.2 Options > Title 

The Options > Title menu item allows to specify a plot title and some notes for the 

chart. The title mask can also be loaded by means of the button shown in the next figure.  

 

The plot title consists in a single line for which the user must specify the text, the colour,  

the size and other options, including background colour. The title is shown on the chart 

only if the Show plot title checkbox is checked. Once plotted, the title can be moved 

on the chart with mouse dragging operations. 
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A sub title with additional information can also be added if needed. Even for the sub title 

it is possible to specify the same parameters described for the title. 

It is also possible to plot some additional information on the chart: the number of calms, 

the prevailing direction, the total number of data, the number of valid data, the average 

value and the maximum value. Each feature is plotted only if the corresponding check 

box is checked. The value of the feature is shown after the corresponding string inserted 

by the user. Once plotted, the notes block can be moved on the chart with mouse dragging 

operations. Calms and valid data will be expressed as a percentage if the corresponding 

checkbox is checked. The number of decimal points for the percentages of calms and 

valid data, and for the average and maximum value of the directional variable is controlled 

by means of four combo boxes.  

The mask that allows to modify the titles can be also activated by right clicking over the 

title, sub titles and notes. 
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7.3.3 Options > Logo 

The Options > Logo menu item allows to specify a logo image for the the chart. The 

logo mask can also be loaded by means of the button shown in the next figure.  
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The user has the possibility to load a specific logo image and to represent it over the 

chart. The  button allows to browse within the user's PC to select the image 

representing the logo. Images can be JPG, PNG or GIF.  

Once plotted the logo can be moved on the chart with mouse dragging operations. 

 

7.3.4 Options > Calms 

The Options > Calms menu item allows to specify to specify if calms must be analysed, 

to set a speed threshold for such calms and to choose if they must be represented in the 

wind rose. The calms mask can also be loaded by means of the button shown in the next 

figure.  

 

If calms must be analysed, the user must indicate a threshold for such events (0.5 in the 

example below). 
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7.3.5 Options > Legend 

The Options > Legend menu item allows to specify a legend must be drawn on the  

the chart. The legend mask can also be loaded by means of the button shown in the next 

figure. 

 

The legend is shown on the chart only if the Draw legend checkbox is checked. A 

legend title and its colour can be specified. If the Unique colour for all the 

labels checkbox is checked, all the labels are plotted with the colour selected in this 

mask, otherwise a different colour for each label is used (the same colour used for the 

intervals). The legend background colour can also be specified. 

When the plot of minimum and/or average and/or maximum values must be done, the 

corresponding colours are specified in this mask. 

Once plotted, the legend can be moved on the chart with mouse dragging operations. 

 

The Add percentages checkbox allows to write the percentages of each category 

within the legend, and the Decimals list controls the number of decimals written in the 

percentages. As an example, in the left hand side of the following figure is shown a legend 
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obtained by checking the  Add percentages checkbox and selecting 1 decimal. If the 

checkbox is not checked, the same legend appears as shown on the right hand side. 

     

7.3.6 Options > Types 

The Options > Types menu item allows to specify which plot type must be produced. 

The plot type mask can also be loaded by means of the button shown in the next figure.  

 

Four types of chart can be produced: wind roses, raw data, rays and 

minimum/average/maximum/percentile data value per direction. 

Note that if the user selects at the same time minimum, maximum and mean, such values 

will be represented over the same plot, and the minimum values could be not visible very 

well. To avoid this problem the user can choose to produce plot of minimum values only. 

Be aware that if the speeds are zero for all the directions, the minimum values plot will be 

not produced. 

On the contrary, the percentiles will be always plotted alone (i.e. without minimum, mean 

and maximum). The percentiles are useful for example, for plotting pollution roses 

because they allow to filter possible outlier from the plot (outliers that are present when 

the plot of maximum values is produced). In order to create the plot of percentiles the 

user must specify the value of the percentile to plot, which is a number between 0 and 

100, extremes excluded. 

When reading a third variable from Microsoft Excel, it is possible to produce raw data 

plot depending on direction and the values of the two variables by selecting the Raw data 
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option. This is called three variables plot or ternary plot. A three variable plot can be 

produced for example by using wind direction, wind speed and the concentration values 

of a specific pollutant. A polar coordinate system is used in this kind of plots: the distance 

of each point from the centre (pole) is determined by the wind speed, the angle from North 

in clockwise direction is determined by the wind direction, and the colour and/or size of 

the point depends on the concentration level. The input mask allows to specify if the points 

must be filled or not, to select their size if they must be of fixed size, and to define a scale 

in pixel/units (e.g. pixels per µg/m3 of a specific pollutant) if their size depends on the 

value of the third variable. 

The default number of directions considered for the wind rose is 16, but it is also possible 

to choose a different number of directions from a list. Possible numbers are: 4, 8, 10, 12, 

16, 18, 20, 36, 72, 100, 120, 180, 240, 300 and 360. The user must be aware that, starting 

from 72 directions the chart might show strange lines, particularly for PC with low quality 

graphical cards. 
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7.3.7 Options > Scales 

The Options > Scales menu item allows to specify a scale for the plot. The plot scale 

mask can also be loaded by means of the button shown in the next figure.  

 

If the Use fixed size checkbox is checked, the plot is automatically scaled to the 

maximum possible plotting dimension. 
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Otherwise two different plot scales can be specified, one for the wind roses and the other 

one for the other types of plot (average wind, raw data, etc.). The wind rose scale can be 

specified in terms of number of drawing points each percent of data, or by number of 

drawing points each event. In order to compare different wind roses, the same scale in 

terms of number of points per percent of data must be used. For the other types of plots 

the scale indicates the number of points per unit of data, for example number of points 

per 1 m/s when plotting the average wind speed. 

 

The plot scale can also be controlled from the main software mask by means of the zoom 

in and zoom out buttons represented in the following figure. The number in the drop list 

indicates the zooming step, while the number within the textbox (13 in the example) 

represents the current scale factor. Note that the zooming buttons automatically modify 

the scales indicated in the previous mask. If the Use fixed size checkbox is checked 

the zooming buttons are not enabled. 

 

7.3.8 Options > Circles 

The Options > Circles menu item allows to specify if circles must be represented on 

the plot. The circle mask can also be loaded by means of the button shown in the next 

figure. 
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A fixed number of circles or equispaced circles can be represented over the plot. It is 

possible to choose their colour, width and style. The user must also specify the angle of 

the imaginary segment over which percentages or values are written. The angle starts 

from North and increases clockwise (i.e. 0 is North, 90 is East, 180 is South, ...). 

It is possible to specify the number of circles to draw (if the Fixed number option is 

selected) or, alternatively, the constant distance between circles (if the Fixed step 

option is selected). In both cases the maximum number of circles that can be drawn is 

10, therefore the software will issue a warning message if the value of the step is too 

small and too many circles would be produced. Please note that the step represents a 

percentage if a wind rose must be produced, while in all the other cases (raw data, 

rays, ...) the step represents a value (e.g. if a raw data plot of wind direction and wind 

speed in m/s must be produced, a value of 2 in the fixed step field means to draw a circle 

every 2 m/s). 

It is also possible to specify if cardinal points must be printed over the wind rose plot, and 

the labels associated to them. Cardinal labels are written when the Draw cardinal 

points checkbox is checked. The size, colour and boldness of the labels can be defined 

by the user. Opposite cardinal point labels are joined by a line if the user checks the Draw 

lines checkbox. As for the circles, it is possible to specify colour, width and style of the 

lines. 

The user can specify if an inner circle must be drawn. In that case the wind rose will start 

from the border of the circle, not from a single central point. Sometimes the wind rose plot 

could be more clear using this option. The radius of the inner circle is specified as a 

percentage of the maximum radius of the wind rose; the possible values of the percentage 

are in the range [1,30]. This means that the maximum radius of the inner circle can be 

equal to 30% of the maximum radius of the wind rose. The user can also specify a colour 

for the border of the inner circle and a colour for filling the inner circle. 
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7.3.9 Options > Runways 

The Options > Runways menu item allows to specify if runways calculations must be 

carried out. The runways mask can also be loaded by means of the button shown in the 

next figure. 

 

A crosswind is any wind that is blowing perpendicular to a direction. 

In aviation, a crosswind is the component of wind that is blowing across the runway 

making a landing more difficult than if the wind were blowing straight down the runway. If 

a crosswind is strong enough it may exceed an aircraft's crosswind limit and an attempt 

to land under such conditions could cause structural damage to the aircraft. 

Crosswinds can also occur when travelling on roads, especially on large bridges and 

highways, which can be dangerous for motorists because of possible lift force created as 

well as causing the vehicle to change direction of travel. 
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Each aircraft has a uniquely stated maximum crosswind component derived from flight 

test experiments. For example a Boeing 727-200 has a maximum crosswind component 

of 35 knots, while a Cessna 172 has a maximum crosswind component of 17 knots. 

According to the Federal Aviation Administration (FAA AC 150/5300-13) a runway 

orientation must satisfy 95% coverage considering yearly wind conditions. This means 

that for the 95% of the time, the crosswind component must be smaller than the maximum 

crosswind component of the aircrafts landing in such airport. 

 

WindRose PRO can be used for calculating crosswinds and to evaluate the correct 

orientation of a runway. It is also possible to find the best orientation for a new runway. It 

is possible to specify a designed, or maximum, crosswind component, using the same 

units of the wind data loaded in WindRose PRO. 

If you want to evaluate the correct orientation of an existing runway, check the Runway 

orientation radio button and specify the orientation in degree. Note that the orientation 

goes from the specified angle to it plus 180. For example an orientation of 45 degrees 

means a runway from NE to SW, while an orientation of 225 degrees means a runway 

from SW to NE. 

If you want to determine the best orientation of a runway, check the Test all 

orientations radio button and specify the angular step which will be applied starting 

from 0 degrees. For example an angular step of 10 degrees means that 36 runway 

orientations will be examined: 0, 10, 20, ..., 350. 

The Gust factor is used to estimate gust values when the input data contain the wind 

speed averaged over a relatively long period of time (e.g. 1-hour averages), if the input 

data already describe the wind gusts, the gust factor must be 1. 
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The output will contain information about the percentage of time above and below the 

design crosswind component, the maximum crosswind from left and right, the maximum 

headwind and the maximum tailwind. 

Since WindRose PRO allows to filter the input data according to date and time, it is 

possible to evaluate the crosswind component even for airports which work only in 

particular seasons (for example during summer) or only during day time. 

This analysis is not available when data are loaded as frequencies. 

7.3.10 Options > Value filtering 

The Options > Value filtering menu item allows to specify if particular values 

must be excluded from the analysis. The value filtering mask can also be loaded by 

means of the button shown in the next figure.  

 

The value filtering mask allows the user to specify the values of directions and data that 

must be filtered (i.e. excluded) from the analysis. 

Both for directions and for data, lower and upper thresholds can be indicated. Values 

smaller than the lower threshold or greater than the upper threshold will be excluded from 

the analysis. Thresholds can be specified also for the third variable, which can be loaded 

only with Microsoft Excel files. 

When filtering options are modified, data must be reloaded, otherwise the filter is not 

applied. 

The filtering options cannot be specified when data are loaded as frequencies. 
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7.3.11 Options > Date time filtering 

The Options > Date time filtering menu item allows to specify if particular dates 

and times must be excluded from the analysis. The date time filtering mask can also be 

loaded by means of the button shown in the next figure.  

 

The date time filtering mask allows the user to filter the data to be analysed according to 

the time and or date associated to the values. This feature can be used only if the user 

specifies a column containing date and time when loads data from a Microsoft Excel file 

or from ASCII files. 

The user may filter the data according to: 

• the year; 

• the month; 

• the day of the week; 

• the hour of the day; 

• the day/night hours. 
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The last two options are alternative. 

The day/night hours are calculated starting from longitude, latitude and time zone 

specified by the user. Please note that: 

• Sunrise and sunset times are based on the ideal situation, where no hills or 

mountains obscure the view and the flat horizon is at the same altitude as the observer. 

Sunrise is the time when the upper part of the Sun is visible, and sunset is when the last 

part of the Sun is about to disappear below the horizon (in clear weather conditions). 

• Daylight saving time is not considered. 

• Atmospheric refraction is not considered. 

When EnergyPlus Weather data are used, longitude and latitude are automatically taken 

from the header records of the input file. 

 

7.3.12 Options > Wind power 

The Options > Wind power menu item allows to specify the features of a wind turbines 

in order to calculate the wind power potential of a location. The wind power mask can 

also be loaded by means of the button shown in the next figure.  
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The wind power potential is calculated only if the Wind power checkbox is checked. 

WindRose PRO assumes that the wind speed at height z can be written as  

𝑢(𝑧) =
𝑢(𝑧0)

𝑘
𝑙𝑛 (

𝑧

𝑧0
) 

where u is the wind speed, z0 is the roughness length (m) and k is the von Karman 

constant. The ratio between the above equation written for the turbine hub height, and 

the same equation written for the anemometer height, allows to project the wind speed at 

the hub height by means of the ratio between two logarithms. 

The roughness length can be determined automatically by the software by selecting the 

land type over which the wind turbine is located. Alternatively its value can be directly 

specified by the user. 
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The user may insert the features of a specific wind turbine, or may select a turbine among 

others loaded from a specific file (*.TRB), (see 7.4.7 ). 

If the user inserts the features of a specific turbine, without using the turbine file (*.TRB), 

the power curve data can also be inserted. Each turbine can be added or modified by 

inserting the corresponding values within the text boxes and clicking the  button. A 

single turbine can be deleted by selecting it within the grid and clicking the  button, 

while the  button deletes all the turbines within the grid. 

The power curve can be graphically represented by means of the  button, as shown 

in the next figure. The chart features can be modified by means of the right panel. Each 

modified option is made visible on the chart only after the  button is clicked. The chart 

can be copied, saved and printed by means of the three buttons placed at the bottom of 

the chart options. 

 

Zooming operations are also possible by clicking over the chart and moving the mouse 

pointer. 
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The Time step represents the time distance in minutes between two consecutive wind 

observations. Such a value must be constant for a correct calculation of the experimental 

capacity factor, that means that the time distance between two consecutive observations 

must be a constant through the file, for example all the observations can be spaced of 60 

minutes. A wrong time step, if smaller than the correct one, will result in a underestimation 

capacity factor (and viceversa). The Total time, expressed in hours, is another important 

parameter for calculating the experimental capacity factor. If the available data cover one 

year (non-leap year), the total time must be 8760 hours, but if the data cover, for example 

four years, the total time must be 35064 hours. A wrong total time, if smaller than the 

correct one, will result in an overestimation of the capacity factor (and viceversa). 

 

The parameters of the Weibull and Rayleigh probability density functions (PDF) are 

calculated by WindRose PRO. 

The PDF of the Weibull distribution for a non null variable x (i.e. x ≥ 0) is described by 

𝑓(𝑥) =
𝑘

𝛬
(
𝑥

𝛬
)
(𝑘−1)

𝑒−(
𝑥
𝛬
)
𝑘

 

where k > 0 is the shape parameter and λ > 0 is the scale parameter. The Weibull 

distribution is related to a number of other probability distributions, for example the 

exponential distribution (k = 1) and the Rayleigh distribution (k = 2). 

The Weibull distribution is particularly important in wind power applications for describing 

the wind speed distribution (i.e. x=v in the previous equation). The shape parameter and 

the scale parameter can be estimated starting from the average wind speed and its 

standard deviation σ, obtained from the measured values, as 1 
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Where Γ is the gamma function. 

                                            

1  Jiang Q., Doyle J.D., Haack T., Dvorak M.J., Archer C.L. and Jacobson M.Z. (2008) Exploring wind energy potential off the 

California coast. Geophysical Research Letters, Vol. 35, L20819. 
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The PDF of the Rayleigh distribution for a non null variable x (i.e. x ≥ 0) is described by 

𝑓(𝑥) =
𝑥

𝛴2
𝑒
−(

𝑥2

2𝛴2
)
 

where σ > 0 is the mode of the distribution. The maximum likelihood estimate of the 

parameter σ is 
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where xi is the value of the ith of the N samplings of the random variable 

 

A Rayleigh distribution is often observed when the overall magnitude of a vector is related 

to its directional components. One example where the Rayleigh distribution naturally 

arises is when wind speed is analysed into its orthogonal 2-dimensional vector 

components. Assuming that the magnitude of each component is uncorrelated and 

normally distributed with equal variance, then the overall wind speed (vector magnitude) 

will be characterized by a Rayleigh distribution.2 

 

Integrating the Weibull PDF between two wind speeds gives the probability that the wind 

speed is between those two values. Therefore it is possible to define the operating 

probability of a wind turbine integrating between the cut-in wind speed vci (the minimum 

wind speed to operate) and the cut-out wind speed vco (the maximum wind speed above 

which the turbine must be turned off for its protection) as (Jiang et al., 2008): 
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The energy output can be estimated by means of an empirical equation3 
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2  http://en.wikipedia.org/wiki/Rayleigh_distribution 

3  Jacobson, M. Z., and G. M. Masters, 2001: Exploiting wind versus coal. Science, 293, 1438. 
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where 8760 are the hours in an year, PRated is the rated power (kW) of the wind turbine, 

D is the blade diameter (m). 

 

7.3.13 Options > Other 

The Options > Other menu item allows to activate other calculation options which are 

detailed in the following. The other options mask can also be loaded by means of the 

button shown in the next figure.  

 

 

Rotate wind direction of 180 deg 

Check this box if the wind direction must be rotated of 180 degrees. This option can be 

useful to switch from wind direction (meant as the direction from which the wind blows) to 

flow direction (meant as the direction towards which the wind blows), or viceversa. 

 

Add date and time to output file name 

Check this box to add date and time to the ASCII analysis output file name. Date and time 

are added with the format YYYYMMDDhhmmss, where YYYY is the year, MM the month, 

DD the day, hh the hour (00-23), mm the minute (00-59) and ss the second (00-59). By 

checking this box a different file will be produced at every analysis, even using the same 

input file. This option is useful when you do not want to overwrite the output file. 
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Write summary 

Check this box to write a summary at the end of the output file generated during the 

analysis (see 7.4.1 ). The summary is generated starting from a template text file specified 

by the user containing specific TAGS. This option can be useful to write a report in short 

time and in the user's own language. The allowed TAGS, which must be specified in 

capital letters, are summarised in the following table. 

An example of template summary is in the Sample directory, whose location depends on 

the operating system. The user can create her/his own templates. The summary can be 

created only when hourly data are analysed (i.e. not frequencies). 

Note that the summary can be written only for 4, 8 and 16 directions. 

 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

53 

 

TAG Variable 

WR_TOTDATA Total number of data 

WR_VALDATA Number of valid data 

WR_PCTDATAVAL Percent of valid data 

WR_W100 Maximum value of data 

WR_W95 95 percentile of data 

WR_W50 50 percentile of data 

WR_DMAX01 1st prevailing direction 

WR_DMAX02 2nd prevailing direction 

WR_DMAX03 3rd prevailing direction 

WR_DMAXPCT01 Percent of data in the 1st prevailing direction 

WR_DMAXPCT02 Percent of data in the 2nd prevailing direction 

WR_DMAXPCT03 Percent of data in the 3rd prevailing direction 

WR_WMAX01 Data value of direction with maximum data 

WR_WMAX02 Data value of direction with 2nd maximum data 

WR_WMAX03 Data value of direction with 3rd maximum data 

WR_WMAXDIR01 Direction with 1st maximum data 

WR_WMAXDIR02 Direction with 2nd maximum data 

WR_WMAXDIR03 Direction with 3rd maximum data 

WR_WAVE01 Data value of direction with 1st average data 

WR_WAVE02 Data value of direction with 2nd average data 

WR_WAVE03 Data value of direction with 3rd average data 

WR_WAVEDIR01 Direction with 1st average data 

WR_WAVEDIR02 Direction with 2nd average data 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

54 

 

WR_WAVEDIR03 Direction with 3rd average data 

 

Erosion potential 

Check this box for calculating the wind erosion emission factors for the selected material. 

The emission factors are calculated for PM30, PM15, PM10 and PM2.5 using the AP42 

methodology (see chapter 13.2.5 "Industrial Wind Erosion" of AP42 for more 

information). The emission factors are calculated under the following assumptions: 

 Input wind speed units are m/s 

 Anemometer height is 10 m above ground 

 Almost flat pile (height/base < 0.2) 

 

Beaufort 

Check this box for calculating the data distribution in terms of Beaufort classes. 

The scale was devised in 1805 by Sir Francis Beaufort, a Royal Navy officer. In the early 

19th Century, naval officers made regular weather observations, but there was no 

standard scale and so they could be very subjective - one man's stiff breeze might be 

another's soft breeze. Beaufort succeeded in standardizing the scale. For additional 

information see for example: http://en.wikipedia.org/wiki/Beaufort_scale. 

A brief description of the 13 Beaufort classes is reported in the following table. 

 

Class Wave heights (m) Description 

0 0 Calm 

1 0-0.2 Light air 

2 0.2-0.5 Light breeze 

3 0.5-1 Gentile breeze 

4 1-2 Moderate breeze 

5 2-3 Fresh breeze 

6 3-4 Strong breeze 
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7 4-5.5 High wind, Moderate gale, Near gale 

8 5.5-7.5 Gale, Fresh gale 

9 7.5-10 Strong gale 

10 10-12.5 Storm, Whole gale 

11 12.5-14 Violent storm 

12 >14 Hurricane force 

 

Autocorrelation and structure function 

The calculation of autocorrelation and structure function for the directional variable is 

activated by checking the corresponding check box and specifying the time length. The 

meaning of the time length (L) depends on the time resolution Δt of the data, for example 

if the data are available every hour (Δt = 1 hour), a value of 24 means to calculate the two 

functions up to a maximum time distance of 24 hours, while if the data are available with 

a time resolution of 15 minutes (Δt = 15 minutes), the same value of 24 means to calculate 

the two functions up to a maximum time distance of 6 hours. Each user must know her/his 

data in order to obtain meaningful results. 

 

The autocorrelation is the correlation of a variable with itself at two different times. The 

degree of correlation of a variable x at time ti=iΔt with itself at a different time ti+k=(i+k)Δt    

is calculated as4 
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where N is the total number of data and k goes from 0 to the time length L. 

The two averages indicated by < … > are calculated as: 
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4  Stull R.L. (1988) An introduction to boundary layer meteorology. Kluwer Academic Publishers, The Netherlands. 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

56 

 










kN

i

kiki x
kN

x
1

1

 

Approximate expressions for the autocorrelation equation also exist5, but the exact one 

reported above is implemented in WindRose PRO3. 

 

The structure function is another statistics to study possible common variations between 

a variable at time ti=iΔt and the same variable at a different time ti+k=(i+k)Δt. It is defined 

as: 
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For the same time (k=0) the autocorrelation is 1 and the structure function is 0. 

 

The maximum value which can be specified in the software for the time length is 999. If 

the time length exceeds the number of valid data the software will not execute the 

calculation of the two functions. 

Autocorrelation and structure function can be calculated only if date/time filtering is not 

applied, otherwise a message similar to the one shown in the next figure is prompted. In 

such case the coefficients will be calculated only after unchecking the “Apply date time 

filter” check box (see 7.3.11 ). 

 

Note that autocorrelation and structure function are misleading if the data are 

characterized by many invalid values. 

The values of the two functions are written in the Notes which can be saved in RTF format. 

They can be also exported in Microsoft Excel format together with the two corresponding 

charts. 

 

                                            

5  Cancino-Solórzano Y., Gutiérrez-Trashorras A.J., Xiberta-Bernat J. (2010) Analytical methods for wind persistence: Their 

application in assessing the best site for a wind farm in the State of Veracruz, Mexico. Renewable Energy, 35, 2844-2852. 
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7.4 Actions 

7.4.1 Actions > Analyse 

The Actions > Analyse menu item allows to analyse the loaded data. The same 

action is carried out by clicking the button shown in the next figure. 

 

During the analysis phase many important tasks are carried out, for example the filtering 

of data according to their values and/or dates and times, the wind power calculations, the 

preparation of the joint frequency distribution of direction and values, and many other. 

The analysis depends on the type of data loaded: time dependent data or frequencies 

(more results are produced for time dependent data than for frequencies). It also depends 

on the user choices (e.g. calculation of the erosion potential, calculation of wind power, 

etc.). 

WindRose PRO produces an output file with the same name of the loaded file and 

extension .TXT (e.g. if the input file is sample.csv, the output file is sample.csv.txt) 

containing information about the data loaded. If the option to add date and time to the  

output file name has been selected, the output file name will also contain date and time, 

therefore if the input file is sample.csv, the output file is 

sample.csv_YYYYMMDDhhmmss.txt, where YYYY is the year, MM the month, DD the 

day, dd the hour, mm the minute and ss the second. In this case at every analysis a 

different file will be produced. 

During the analysis a lot of information is written in Rich Text Format (RTF) within the 

notes in the rightmost part of the main mask (the red rectangle in the following image). 

The user can also write some text within the notes area in order to personalise the 

information. The notes can be saved in a RTF file ( ) or copied within a document ( ). 

If needed, the notes can also be deleted using the  button. 
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7.4.2 Actions > Draw 

The Actions > Draw menu item allows to draw the plot. The same action is carried out 

by clicking the button shown in the next figure. 

 

The draw button allows the user to plot the wind rose or any other selected type of plot. 

This button is enabled only after the data have been analysed. As a result, if you have 

selected to draw a wind rose, the WindRose PRO screen will appear like the following 

one. 
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Note that the four elements on the plot (title, legend, notes and user's logo) can be placed 

anywhere by clicking over each of then with the mouse pointer and dragging. 

You can also select to plot the raw data or the rays plot, in such cases the WindRose 

PRO screen will appear like the following two images. These two plots are particularly 

useful when a third variable is loaded (from Microsoft Excel). For example the user can 

load wind direction, wind speed and the concentration of a pollutant (all the three variables 

measured from the same monitoring station). Then the raw data plot will show circles of 

different colours (representing different concentration levels) at different positions 

depending on wind direction and wind speed. This kind of plot will help to understand, for 

the specific example cited, if high levels of concentrations are often associated to a given 

wind direction, then facilitating the individuation of possible sources. 
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It is possible to represent in the same plot minimum, maximum and average values of 

data. The next figure represents, for example, the average and the maximum values of 

the data for each direction. 

 

7.4.3 Actions > Copy 

The Actions > Copy menu item allows to save the plot in the clipboard. Once in the 

clipboard, you can paste the plot in any document. The same action is carried out by 

clicking the button shown in the next figure. 
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7.4.4 Actions > Save 

The Actions > Save menu item allows to save the plot in raster format. The same 

action is carried out by clicking the button shown in the next figure. 

 

The possible file formats to save the plot are: 

BMP Windows Bitmap 

JPG JPG/JPEG Format 

GIF Compuserve GIF 

ICO Widows Icon 

WMF Windows Metafile Format 

EMF Enhanced Metafile Format 

PNG Portable Network Graphics 

TIFF Tagged Image File Format 

EXIF Exchangeable Image File Format 

7.4.5 Actions > Export 

The Actions > Export menu item allows to export the results in different formats, as 

shown in the next figure. 

 

The same action is carried out by clicking the button shown in the next figure. 
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The numerical results can be exported as ASCII files or as Microsoft Excel files. The 

graphical results can be exported in KML format for Google Earth, SHP format for GIS 

systems, and DXF format for CAD systems. 

7.4.5.1 Actions > Export > ASCII output 

This menu item allows to view the output file (the file with .TXT extension) using the 

Notepad application installed on the user's PC. 

An example of the ASCII output file is reported in the following box. This information and 

other, together with automatically produced charts, are also reported in a Microsoft Excel 

file if the user decides to export it (note that Microsoft Excel must be installed on the PC). 

---------------------------------------------------- 

WindRose PRO is copyright Enviroware srl (2013) 

             http://www.enviroware.com 

---------------------------------------------------- 

 

File created on 1/4/2012 7:04:57 PM 

WindRose PRO 

 

Input file: C:\ProgramData\Enviroware\WINDROSEPRO\sample.xlsx 

Configuration file: C:\ProgramData\Enviroware\WINDROSEPRO\sample.wro3 

 

Total data: 8769 

Valid data: 8769 (100.00% of total data) 

 

*************************** 

Date/time filtering options 

*************************** 

 

Years from 1000 to 3000 

Months: Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec  

Days: Mon Tue Wed Thu Fri Sat Sun  

Hours: 00 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23  

 

Number of data after filtering: 8768 

 

 

***************** 

Data distribution 

***************** 

Minimum         0 

5th percentile  0.5 

25th percentile 1.2 

50th percentile 2.1 
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75th percentile 4.3 

95th percentile 10.6 

Maximum         24.4 

 

********************** 

Rose on 16 directions. 

********************** 

Dir    Angle(deg)    Percent 

0     0.000       2.384 

1     22.500       5.212 

2     45.000       10.185 

3     67.500       5.965 

4     90.000       4.174 

5     112.500       2.486 

6     135.000       1.460 

7     157.500       0.684 

8     180.000       1.300 

9     202.500       11.097 

10     225.000       23.061 

11     247.500       5.075 

12     270.000       1.791 

13     292.500       1.802 

14     315.000       2.475 

15     337.500       2.019 

 

************************************************************* 

Second variable (wind speed, stability, ...) on 7 intervals. 

************************************************************* 

Int.       From       To       Data       Percent 

00         1    2  2647        30.189 

01         2    3  1512        17.245 

02         3    4  656         7.482 

03         4    5  427         4.870 

04         5    6  343         3.912 

05         6    7  329         3.752 

06         7    100  1203        13.720 

 

Input directions rotated of 0 deg. 

 

Maximum data value (units of input) 24.4 

 

************************************** 

Joint frequencies (directions on rows) 

************************************** 

92     71     34     8      0      3      1 

237    166    46     7      1      0      0 

581    222    65     15     8      2      0 

342    132    34     15     0      0      0 

197    126    32     6      5      0      0 

104    99     14     1      0      0      0 

76     49     3      0      0      0      0 

41     13     6      0      0      0      0 

49     21     13     14     8      1      8 

106    93     100    93     74     93     414 

228    245    216    218    217    209    689 

155    95     49     23     24     16     83 

91     40     16     6      1      0      3 

99     39     12     1      1      1      5 

143    54     9      8      2      1      0 

106    47     7      12     2      3      0 

 

**************************************************************** 

Average data value along each direction (in units of input data) 

**************************************************************** 

Dir    Angle(deg)    #Data      Min     Mean    Max 

0     0.000       434         0.000   1.264   7.700 

1     22.500       588         0.300   1.809   5.700 

2     45.000       1162        0.300   1.704   6.700 

3     67.500       726         0.300   1.620   5.000 

4     90.000       452         0.300   1.865   5.300 
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5     112.500       267         0.300   1.836   4.200 

6     135.000       164         0.300   1.658   3.800 

7     157.500       99          0.300   1.425   3.800 

8     180.000       157         0.300   2.500   12.500 

9     202.500       1064        0.300   6.470   23.000 

10     225.000       2133        0.300   5.687   24.400 

11     247.500       532         0.300   3.778   22.200 

12     270.000       239         0.300   1.710   14.700 

13     292.500       232         0.300   1.790   14.600 

14     315.000       275         0.300   1.771   6.400 

15     337.500       244         0.300   1.762   6.700 

 

 

******************* 

Circular statistics  

******************* 

 

Interval: 0 - 1 

Counts: 1495 

Scalar average of direction: 36.110 

Scalar average of data: 0.726 

Vector average of direction: 36.733 

Vector average of data: 0.171 

Persistence: 0.235 

Standard deviation of direction: 88.240 

Root mean square of data: 0.754 

Variance of data: 0.042 

Variance of the X component of data: 0.301 

Variance of the Y component of data: 0.238 

Covariance of the X and Y components of data: 0.093 

Cross wind data variance: 0.189 

Along wind data variance: 0.350 

 

Interval: 1 - 2 

Counts: 2648 

Scalar average of direction: 40.392 

Scalar average of data: 1.530 

Vector average of direction: 40.278 

Vector average of data: 0.450 

Persistence: 0.294 

Standard deviation of direction: 82.374 

Root mean square of data: 1.555 

Variance of data: 0.080 

Variance of the X component of data: 1.263 

Variance of the Y component of data: 0.953 

Covariance of the X and Y components of data: 0.322 

Cross wind data variance: 0.816 

Along wind data variance: 1.401 

 

Interval: 2 - 3 

Counts: 1512 

Scalar average of direction: 55.609 

Scalar average of data: 2.481 

Vector average of direction: 56.634 

Vector average of data: 0.343 

Persistence: 0.138 

Standard deviation of direction: 93.876 

Root mean square of data: 2.498 

Variance of data: 0.085 

Variance of the X component of data: 3.256 

Variance of the Y component of data: 2.866 

Covariance of the X and Y components of data: 1.195 

Cross wind data variance: 1.886 

Along wind data variance: 4.236 

 

Interval: 3 - 4 

Counts: 656 

Scalar average of direction: 223.268 

Scalar average of data: 3.510 

Vector average of direction: 223.140 
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Vector average of data: 1.047 

Persistence: 0.298 

Standard deviation of direction: 83.341 

Root mean square of data: 3.525 

Variance of data: 0.104 

Variance of the X component of data: 5.371 

Variance of the Y component of data: 5.956 

Covariance of the X and Y components of data: 3.370 

Cross wind data variance: 2.281 

Along wind data variance: 9.046 

 

Interval: 4 - 5 

Counts: 427 

Scalar average of direction: 223.336 

Scalar average of data: 4.516 

Vector average of direction: 223.129 

Vector average of data: 3.117 

Persistence: 0.690 

Standard deviation of direction: 49.897 

Root mean square of data: 4.531 

Variance of data: 0.132 

Variance of the X component of data: 4.491 

Variance of the Y component of data: 6.322 

Covariance of the X and Y components of data: 2.840 

Cross wind data variance: 2.513 

Along wind data variance: 8.301 

 

Interval: 5 - 6 

Counts: 343 

Scalar average of direction: 222.274 

Scalar average of data: 5.519 

Vector average of direction: 222.210 

Vector average of data: 4.905 

Persistence: 0.889 

Standard deviation of direction: 28.459 

Root mean square of data: 5.534 

Variance of data: 0.167 

Variance of the X component of data: 3.193 

Variance of the Y component of data: 3.377 

Covariance of the X and Y components of data: 1.306 

Cross wind data variance: 1.976 

Along wind data variance: 4.593 

 

Interval: 6 - 100 

Counts: 1532 

Scalar average of direction: 220.869 

Scalar average of data: 9.558 

Vector average of direction: 220.417 

Vector average of data: 9.212 

Persistence: 0.964 

Standard deviation of direction: 16.090 

Root mean square of data: 10.059 

Variance of data: 9.842 

Variance of the X component of data: 6.390 

Variance of the Y component of data: 9.935 

Covariance of the X and Y components of data: 2.049 

Cross wind data variance: 5.858 

Along wind data variance: 10.467 

 

Interval: All data 

Counts: 8613 

Scalar average of direction: 221.048 

Scalar average of data: 3.445 

Vector average of direction: 220.494 

Vector average of data: 1.841 

Persistence: 0.534 

Standard deviation of direction: 96.611 

Root mean square of data: 4.809 

Variance of data: 11.262 

Variance of the X component of data: 8.569 
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Variance of the Y component of data: 11.172 

Covariance of the X and Y components of data: 7.721 

Cross wind data variance: 2.041 

Along wind data variance: 17.699 

 

************************************** 

Autocorrelation and structure function 

************************************** 

 

Distance Autocorrelation Structure function 

0 1.000E+000 0.000E+000 

1 7.156E-001 6.860E+000 

2 6.212E-001 9.136E+000 

3 5.450E-001 1.097E+001 

4 4.661E-001 1.287E+001 

5 3.996E-001 1.447E+001 

6 3.366E-001 1.599E+001 

7 2.750E-001 1.748E+001 

8 2.259E-001 1.866E+001 

9 1.862E-001 1.962E+001 

10 1.670E-001 2.008E+001 

11 1.443E-001 2.063E+001 

12 1.301E-001 2.096E+001 

13 1.197E-001 2.121E+001 

14 1.089E-001 2.147E+001 

15 1.114E-001 2.141E+001 

16 1.205E-001 2.119E+001 

17 1.357E-001 2.082E+001 

18 1.627E-001 2.017E+001 

19 1.906E-001 1.949E+001 

20 2.259E-001 1.864E+001 

21 2.627E-001 1.776E+001 

22 2.926E-001 1.703E+001 

23 3.178E-001 1.643E+001 

24 3.222E-001 1.632E+001 

 

 

 

*********** 

Typical day 

*********** 

 

Hour AveDir AveData StdDevDir StdDevData Events 

00 226.503 3.386 84.962 3.250 366 

01 233.995 3.339 85.390 3.310 366 

02 230.291 3.340 85.291 3.377 366 

03 231.665 3.293 83.635 3.292 366 

04 236.941 3.165 84.777 3.290 365 

05 239.678 3.068 86.791 3.299 365 

06 238.382 3.009 86.892 3.326 365 

07 248.409 2.886 87.227 3.240 365 

08 258.841 2.885 92.700 3.214 365 

09 291.097 2.987 96.853 3.200 365 

10 332.391 3.034 96.084 3.212 365 

11 5.250 3.147 92.088 3.177 365 

12 15.073 3.312 90.634 3.294 365 

13 28.446 3.512 90.584 3.397 365 

14 44.363 3.732 89.933 3.455 365 

15 53.892 3.862 92.092 3.560 365 

16 64.338 3.832 94.876 3.630 365 

17 96.635 3.843 97.644 3.518 365 

18 141.935 3.702 96.976 3.426 365 

19 163.575 3.668 91.694 3.393 365 

20 181.537 3.577 86.661 3.203 366 

21 199.419 3.541 82.718 3.210 366 

22 212.213 3.552 83.759 3.436 366 

23 216.187 3.553 83.790 3.472 366 

 

***************************** 

Hourly direction distribution 
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***************************** 

 

Hour Dir00 Dir01 Dir02 Dir03 Dir04 Dir05 Dir06 Dir07 Dir08 Dir09 Dir10 Dir11

 Dir12 Dir13 Dir14 Dir15  

00 6.557 4.645 5.464 5.738 4.098 6.831 1.639 1.093 1.366 14.481 28.962 7.377

 1.913 3.279 2.732 3.825 

01 6.284 4.645 8.197 5.464 4.372 4.372 2.459 0.546 1.639 12.842 26.503 9.836

 3.279 3.552 4.372 1.639 

02 4.918 4.098 8.470 6.011 4.645 4.372 1.366 1.366 1.639 14.481 25.683 10.656

 2.186 3.825 3.279 3.005 

03 5.738 4.372 5.738 6.284 4.645 3.005 2.732 1.639 1.913 15.027 26.503 6.284

 5.738 3.279 3.279 3.825 

04 6.301 5.205 7.123 4.658 6.027 2.192 2.466 1.370 0.822 13.425 26.301 9.863

 4.110 3.562 3.562 3.014 

05 6.027 3.562 9.041 5.753 5.479 3.014 1.370 0.548 3.014 11.781 26.301 7.945

 4.932 4.384 2.466 4.384 

06 5.479 3.836 11.233 4.658 5.205 3.014 1.370 0.822 1.644 12.055 27.123 8.493

 5.753 3.014 2.740 3.562 

07 7.123 5.479 8.767 7.397 2.740 1.370 2.466 0.822 1.644 12.877 24.110 8.767

 4.110 5.479 3.562 3.288 

08 7.945 6.849 12.329 5.753 4.110 2.192 1.096 0.822 1.644 13.425 21.918 7.397

 4.384 3.288 4.384 2.466 

09 5.753 8.767 13.425 9.863 2.192 2.466 0.548 0.822 2.192 11.233 20.822 5.753

 4.110 3.836 4.932 3.288 

10 5.753 8.219 19.452 7.123 3.288 2.466 0.274 0.548 1.918 9.863 20.274 5.753

 2.466 2.740 5.753 4.110 

11 3.836 11.507 20.548 9.589 4.110 1.096 0.274 0.274 1.370 9.863 18.630 3.014

 3.288 3.014 5.479 4.110 

12 4.932 13.699 22.192 9.315 2.740 0.822 1.096 0.274 0.822 8.767 20.000 3.836

 1.370 2.466 4.384 3.288 

13 3.836 12.603 25.753 10.137 2.466 1.096 0.274 0.274 1.096 9.863 20.822 2.466

 1.370 1.918 3.014 3.014 

14 2.466 12.055 26.027 12.329 3.562 0.822 0.274 0.822 1.096 10.137 21.370 1.918

 1.096 1.370 1.918 2.740 

15 3.288 10.137 22.466 13.699 6.301 0.548 0.822 0.548 0.274 11.507 20.548 3.562

 0.822 0.822 2.192 2.466 

16 4.110 7.123 21.370 12.329 7.671 1.918 0.548 0.548 1.370 12.055 20.548 3.562

 0.274 1.096 3.014 2.466 

17 1.918 7.397 17.260 12.877 9.589 3.288 0.274 0.274 1.096 11.507 22.466 4.658

 2.192 1.370 2.192 1.644 

18 3.288 5.479 15.342 10.411 9.041 4.658 2.192 1.096 0.822 12.329 22.192 6.575

 1.096 2.466 2.192 0.822 

19 3.014 5.479 10.685 10.411 10.685 3.836 4.384 0.548 2.740 12.329 24.932 6.027

 1.918 0.548 1.644 0.822 

20 4.645 3.005 9.016 7.377 8.197 6.557 3.552 3.005 3.825 11.749 28.962 3.279

 1.639 1.366 2.459 1.366 

21 4.645 4.645 6.284 7.377 4.098 4.918 6.831 2.186 3.005 14.481 28.415 6.011

 2.732 1.913 1.093 1.366 

22 4.918 4.918 6.284 7.104 4.918 3.005 4.098 3.279 3.005 12.842 30.055 6.011

 3.279 2.459 1.366 2.459 

23 6.011 3.279 5.738 7.104 3.552 5.191 2.459 3.552 3.005 12.295 30.328 6.557

 1.366 2.459 3.279 3.825 

 

 

************************ 

Hourly data distribution 

************************ 

 

Hour Data00 Data01 Data02 Data03 Data04 Data05 Data06  

00 25.956 13.661 10.656 6.284 3.552 3.552 14.208 

01 28.689 16.120 8.197 5.738 3.279 5.191 12.568 

02 30.328 16.393 8.197 4.918 4.098 2.732 13.661 

03 29.508 17.213 7.377 5.464 4.372 3.005 12.842 

04 29.589 16.164 7.945 6.027 3.836 4.384 9.863 

05 29.041 16.986 6.849 5.205 5.205 3.288 9.589 

06 28.219 18.082 7.671 4.658 2.192 4.932 9.589 

07 28.219 16.164 6.301 3.288 4.384 2.740 10.411 

08 26.301 15.068 6.849 4.932 4.658 1.918 10.411 

09 31.233 14.521 8.219 4.384 2.740 1.918 11.781 

10 33.151 17.534 5.479 5.479 2.740 2.192 11.781 
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11 35.616 17.534 4.658 4.110 1.644 4.658 12.603 

12 36.164 19.452 6.027 2.192 3.014 4.110 13.699 

13 37.808 17.534 6.301 4.658 3.836 2.740 15.342 

14 34.795 21.370 6.575 6.027 3.562 3.014 16.164 

15 34.247 20.548 6.849 5.479 4.658 4.658 16.164 

16 34.521 14.521 8.219 3.836 4.384 5.205 16.986 

17 32.603 18.082 6.849 3.836 5.205 4.110 17.808 

18 32.329 13.973 7.671 4.932 4.658 4.932 16.712 

19 26.575 18.356 7.397 3.836 5.205 3.836 16.712 

20 22.951 21.038 9.836 3.552 4.098 4.372 16.120 

21 25.410 19.672 9.290 6.011 3.005 4.372 15.301 

22 28.962 15.027 8.743 6.557 4.372 4.645 13.661 

23 22.404 18.852 7.377 5.464 5.191 3.552 15.301 

 

 

************************************ 

Wind power information at hub height 

************************************ 

 

Anemometer height (m): 10 

Hub height (m): 67 

Air density (kg/m3): 1.225 

Average wind speed (m/s): 4.782171 

Wind speed standard deviation (m/s): 4.744024 

Reileigh distribution parameter (m2/s2): 4.762864 

Weibull shape parameter (-): 1.008736 

Weibull scale parameter (-): 4.800548 

Theoretical operating probability (-): 0.531597 

Theoretical energy output (kWh): 2963251 

Theoretical annual specific yeld (kWh/m2): 465.7936 

Actual energy output (kWh): 2850361 

Actual annual specific yeld (kWh/m2): 448.0484 

 

Bin size (m/s): 1 

Bin Speed(m/s) Actual probability Weibull Rayleigh Working 

0 0.500 1.036E-001 1.860E-001 2.192E-002 0 

1 1.500 2.137E-001 1.527E-001 6.292E-002 0 

2 2.500 1.984E-001 1.245E-001 9.602E-002 0 

3 3.500 1.216E-001 1.013E-001 1.178E-001 4207 

4 4.500 6.581E-002 8.229E-002 1.270E-001 3141 

5 5.500 4.562E-002 6.681E-002 1.245E-001 2564 

6 6.500 3.228E-002 5.420E-002 1.129E-001 2164 

7 7.500 2.931E-002 4.396E-002 9.569E-002 1881 

8 8.500 2.737E-002 3.563E-002 7.622E-002 1624 

9 9.500 2.509E-002 2.887E-002 5.729E-002 1384 

10 10.500 2.486E-002 2.339E-002 4.075E-002 1164 

11 11.500 1.848E-002 1.894E-002 2.748E-002 946 

12 12.500 2.110E-002 1.534E-002 1.760E-002 784 

13 13.500 1.357E-002 1.242E-002 1.072E-002 599 

14 14.500 1.106E-002 1.005E-002 6.209E-003 480 

15 15.500 8.896E-003 8.133E-003 3.426E-003 383 

16 16.500 7.641E-003 6.581E-003 1.802E-003 305 

17 17.500 6.159E-003 5.324E-003 9.032E-004 238 

18 18.500 4.220E-003 4.306E-003 4.318E-004 184 

19 19.500 4.106E-003 3.483E-003 1.970E-004 147 

20 20.500 3.422E-003 2.817E-003 8.575E-005 111 

21 21.500 2.509E-003 2.278E-003 3.564E-005 81 

22 22.500 2.509E-003 1.841E-003 1.414E-005 59 

23 23.500 2.395E-003 1.489E-003 5.358E-006 37 

24 24.500 1.825E-003 1.203E-003 1.939E-006 16 

25 25.500 1.597E-003 9.727E-004 6.705E-007 0 

26 26.500 7.984E-004 7.862E-004 2.215E-007 0 

27 27.500 3.422E-004 6.354E-004 6.991E-008 0 

28 28.500 3.422E-004 5.134E-004 2.109E-008 0 

29 29.500 4.562E-004 4.149E-004 6.078E-009 0 

30 30.500 3.422E-004 3.352E-004 1.675E-009 0 

31 31.500 2.281E-004 2.708E-004 4.410E-010 0 

32 32.500 1.141E-004 2.188E-004 1.110E-010 0 

33 33.500 0.000E+000 1.767E-004 2.671E-011 0 

34 34.500 2.281E-004 1.428E-004 6.146E-012 0 
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****************************************** 

Wind power (W) across a 1 m2 surface of 

undisturbed wind streaming (i.e. no rotor) 

Assumptions: 

1) Air density 1.225 kg/m3 

2) No power coefficient applied (Betz law) 

3) Wind speed units are m/s 

****************************************** 

Percentile Power(W/m2) 

1 0.0 

5 0.2 

10 0.6 

25 3.0 

50 16.0 

75 137.4 

90 952.8 

95 2000.5 

99 6687.5 

100 25103.6 

 

*********************************************** 

Emission factor (g/m2) due to wind erosion 

calculated using the AP42 methodology 

(chapter 13.2.5 Industrial wind erosion). 

 Multiply the emission factor and the 

exposed surface to get the total emissions over 

the period. 

Assumptions: 

1) Wind speed units are m/s 

2) Anemometer height is 10 m above ground 

3) Almost flat pile (height/base < 0.2) 

*********************************************** 

Material: Overburden 

Number of disturbing events: 82 

Emission factor for PM30  (g/m2): 4.362e+002 

Emission factor for PM15  (g/m2): 2.617e+002 

Emission factor for PM10  (g/m2): 2.181e+002 

Emission factor for PM2.5 (g/m2): 3.272e+001 

 

 

*********************************************** 

Crosswind and runway orientation 

*********************************************** 

Design crosswind component: 150 (user input units) 

Runway orientation: 110 degree 

Percent above design crosswind component: 0.000 

Percent below design crosswind component: 100.000 

Maximum crosswind from left: -7.4 m/s 

Maximum crosswind from right: 22.8 m/s 

Maximum headwind: 5.1 m/s 

Maximum tailwind: -14.6 m/s 

 

 

******* 

Summary 

******* 

 

The maximum wind speed is 2.440E+001 m/s, the 95th percentile is 1.050E+001 m/s 

and the median is 2.100E+000 m/s. 

The prevailing wind direction is SW with 1.11E+01% of data, 

while the second prevailing direction is SSW with 1.11E+01% of data. 

The maximum wind speed (24.400 m/s) comes from SW, while the 

maximum average speed (6.470 m/s) comes from SSW. 
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7.4.5.2 Actions > Export > Excel 

This menu item allows to create an output file in Microsoft Excel format. Microsoft Excel 

must be installed on the user's PC. The Microsoft Excel file contains different information 

depending on the input data (frequencies or time-dependent records). 

The output Microsoft Excel file will contain a number of worksheets which varies as 

function of the user's choices. Anyway, the maximum number of worksheets within the 

exported Excel file is eight, and their names and contents are reported in the following 

table. 

 

Worksheet Summary contains the creation date, the name of the data file analysed, the 

name of the configuration file used, the number of data (total, valid, etc.), the filtering 

options, etc. 

 

Worksheet Erosion contains information about the erosion calculation, which means the 

number of disturbing events and the emission factors in terms of g/m2 for PM30, PM15, 

PM10 and PM2.5. This worksheet is produced only if the user selects the erosion 

calculation option (see 7.3.13 ). 

 

Worksheet Distributions contains, for each direction, the number of data, the percent of 

data, and minimum, average and maximum values. It also contains the data distribution 

(number and percent) for the classes of directional variable (for example for each wind 

speed class). The percentiles of directional data values are also in this worksheet. Two 

charts are also present, one for the percentiles of directional data, and one for their 

minimum, average and maximum value for each direction. The autocorrelation and the 

structure function charts are also present if the user requested  their calculation. An 

example of such worksheet is reported in the next figure. 
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Worksheet Joint frequencies contains the number of events for each couple of direction 

class and data class. An example is reported in the following table for 16 classes of 

directions and 7 classes of the directional variable values. For example, there are 222 

events for direction 45 degrees and data values between 2 and 3. 

 

 1 - 2 2 - 3 3 - 4 4 - 5 5 - 6 6 - 7 7 - 100 

0 92 71 34 8 0 3 1 

22.5 237 166 46 7 1 0 0 

45 581 222 65 15 8 2 0 

67.5 342 132 34 15 0 0 0 

90 197 126 32 6 5 0 0 

112.5 104 99 14 1 0 0 0 

135 76 49 3 0 0 0 0 

157.5 41 13 6 0 0 0 0 
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180 49 21 13 14 8 1 8 

202.5 106 93 100 93 74 93 414 

225 228 245 216 218 217 209 689 

247.5 155 95 49 23 24 16 83 

270 91 40 16 6 1 0 3 

292.5 99 39 12 1 1 1 5 

315 143 54 9 8 2 1 0 

337.5 106 47 7 12 2 3 0 

 

Worksheet Circular statistics contains such statistics for all the data used to create the 

wind rose, and for each single interval (for example, considering wind speed, for the 

intervals 0-1 m/s, 1-2 m/s, 2-3 m/s, and so on). The worksheet contains a table with the 

following fields for each interval and for all the data: 

 counts 

 scalar average of direction 

 scalar average of directional data (e.g. wind speed) 

 vector average of direction 

 vector average of directional data 

 persistence 

 standard deviation of direction 

 root mean square of directional data 

 variance of directional data 

 variance of the X component of directional data 

 variance of the Y component of directional data 

 covariance of the X and Y components of directional data 

 crosswind data variance 

 along wind data variance. 

 

Worksheet Exceeding frequencies contains the number of events and the frequencies 

for each data interval, and the number of exceeding events and the exceeding 

frequencies with respect to the first value of the interval. The exceeding frequencies are 

calculated using > or ≥ according to the user specifications (see paragraph 7.3.1 ). An 
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example is reported in the following figure. The chart of the exceeding frequencies is also 

automatically produced. 

 

 

 

Worksheet Monthly data distribution contains, for each month, the average value of the 

directional variable (e.g. wind speed) and the values corresponding to each percentile. 

Note that this worksheet is produced only if date and time are available and loaded. An 

example of such worksheet is reported in the next figure. 

 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

75 

 

 

 

Worksheet Wind power is produced only if the user requested the calculation of such 

variable. It contains a summary of the input data and many variables useful to evaluate 

the wind energy available, for example the capacity factor, the Weibull distribution 

parameters, the wind power density distributions and others. The chart of the wind power 

density distribution is also present. An example of such worksheet is reported in the next 

figure. 
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Worksheet Typical day contains the typical day of direction and directional variable. This 

means that, for each hour of the day (which is not filtered according to the user 

instructions), the average of direction and directional variable are calculated. The 

averages, together with the number of events used to calculate them and to their standard 

deviations are reported within the worksheet. The chart of the typical day is also present 

within the worksheet. Note that this worksheet is produced only if date and time are 

available and loaded. An example of such worksheet is reported in the next figure. 
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Worksheet Hourly dir distribution contains the distribution of directions for each hour of 

the day. This information is useful to evaluate how, on average, the directions change 

during the day. For example, the analysis of wind directions measured close to the coast 

might show the sea breeze effect. The chart of the hourly direction distribution is also 

present within the worksheet. Note that this worksheet is produced only if date and time 

are available and loaded. An example of such worksheet is reported in the next figure. 
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Worksheet Hourly data distribution contains the distribution of the directional variable 

values for each hour of the day. This information is useful to evaluate how, on average, 

the directions change during the day. For example, the analysis of wind directions 

measured close to the coast might show the sea breeze effect. The chart of the hourly 

data distribution is also present within the worksheet. Note that this worksheet is produced 

only if date and time are available and loaded. An example of such worksheet is reported 

in the next figure. 
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Worksheet Crosswind contains the information about crosswind and tailwind 

calculations, and the percentage of data above the design crosswind component. This 

information is reported for a single direction or for many directions, according to the user  

specifications (see 7.3.9 ). Note that this worksheet is produced only if the user selected 

such analysis. 

7.4.5.3 Actions > Export > KML 

This menu item allows to export the wind rose in KML format, and then to import it in 

Google Earth (http://earth.google.com). 

Note than only wind roses can be exported in KML format, not other types of plot. 

The mask for setting the KML options is represented in the following figure (left). 

 

http://www.enviroware.com/
http://earth.google.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

80 

 

 

   

The user must specify the coordinates (longitude and latitude or UTM metric) of the centre 

of the wind rose. Longitude is positive along East; latitude is positive in the Northern 

hemisphere. When EnergyPlus Weather data are used, longitude and latitude are 

automatically taken from the header records of the input file. 

It is possible to select the style of the wind rose: the colours will be those selected for the 

wind rose (see 7.3.1 ), but is is possible to specify the colour and the width of the lines 

and the percentage of opacity (0 means fully transparent and 100 means fully opaque). 

The wind rose can be represented as flat (i.e. with a constant height), or as a pyramid 

specifying a minimum height and a maximum height. 

The view options can be also specified by the user: 

 Range determines the altitude of the eye point (m) 

 Tilt indicates the angle of the eye point to the designated point (deg) [0 from the 

vertical; 90 laterally] 

 Heading describes the angular distance along the horizon to the viewpoint; it is 

measured from north, 90 shows a heading due west. 

The view options can be modified in Google Earth. 
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It is also possible to produce a legend which will be shown on Google Earth. By clicking 

the mouse icon within the legend frame, the mask shown in the right part of the previous 

figure appears. The legend position in Google Earth is determined by clicking the black 

square (which represents the legend) and dragging it over the white rectangle (which 

represents the Google Earth interface). 

The KML file can be exported in any existing directory selected by the user and with any 

name. An example of KML file produced with WindRose PRO and imported in Google 

Earth is represented in the following figure. 

Do not use the symbols > (greater than) or < (smaller than) in the legend caption if 

you plan to export the wind rose in Google Earth, because that might generate a 

parsing error. 

 

7.4.5.4 Actions > Export > SHP 

This menu item allows to export the wind rose as a shapefile, which can be then viewed 

using a GIS (Geographical Information System) tool. Note than only wind roses can be 

exported as shapefiles, not other types of plot. 

The following mask allows to set the shapefile options. 
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The user must specify the metric or geographical (longitude and latitude) coordinates of 

the centre of the wind rose. These coordinates will be used for positioning the plot when 

it is loaded as a layer in a GIS. If the centre is specified by means of its longitude and 

latitude, the coordinates of all the points needed to build the wind rose will be in terms of 

longitude and latitude. This is the reason for which the wind rose sometimes appears a 

bit distorted. Longitude is positive along East; latitude is positive in the Northern 

hemisphere. 

The user also indicates the scale of the wind rose by means of its maximum size in 

metres. 

The DBF file associated to the shapefile contains the following fields: 

 Direction  (direction of the wind rose arm) 

 SpeedLower  (lower limit of the data interval) 

 SpeedUpper  (upper limit of the data interval) 

 Events  (number of events within this direction and data interval) 

 Legend  (legend used within the application) 

 R   (red component of the colour) 

 G   (green component of the colour) 

 B   (blue component of the colour) 
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By means of specific queries, these fields should allow to represent the wind rose within 

the GIS viewer with exactly the same colours and legend captions used within WindRose 

PRO. 

The last record of the DBF file will contain information about the calms, provided the 

“Analyse calms” checkbox has been checked (see 7.3.4 ). The fields Direction, 

SpeedLower and SpeedUpper of this last record will be all equal to -999, and the value 

of the Legend field will always be Calms. 

The percentage circles are not exported in the shapefile. 

The shapefile can be exported in any existing directory selected by the user and with any 

name. Four files will be produced within such directory with the same name and the 

following extensions: SHP, DBF, SHX and PRJ. 

7.4.5.5 Actions > Export > DXF 

This menu item allows to export the wind rose as a DXF file that can be loaded, for 

example, in AutoCAD (Autodesk, Inc.). Note than only wind roses can be exported in 

DXF format, not other types of plot. 

The DXF file can be exported in any existing directory selected by the user and with any 

name. The DXF file is produced according to versions R11/R12 and should be readable 

from all the new versions. 

An example of image obtained importing in AutoCAD (Autodesk, Inc) a DXF produced 

with WindRose PRO is shown below. 
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7.4.6 Actions > Charts 

The Actions > Charts menu item allows to view some charts that are automatically 

produced by the software, as shown in the next figure. 

 

The same action is carried out by clicking the button shown in the next figure. 
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7.4.6.1 Feature common to all the charts 

All the charts have a right panel with elements which allow to modify their features, as 

shown in the next figure. Such elements are within seven groups according to the features 

that they control: Chart title, Legend, X Axis, Y Axis, Y Series, Y2 Axis and 

Y2 Series. After modified, the new features will appear on the chart by clicking the  

button. Note that, depending on the chart, some options might not have effect even if they 

can be modified. For example, the options under Y2 Axis and Y2 Series have not effect 

for charts without the Y2 Axis. 

 

The chart can be copied, saved and printed by means of the three buttons placed at the 

bottom of the chart options. 
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The possible file formats to save the chart are: 

BMP Windows Bitmap 

JPG JPG/JPEG Format 

GIF Compuserve GIF 

EMF Enhanced Metafile Format 

PNG Portable Network Graphics 

TIFF Tagged Image File Format 

Note that by clicking over the chart and dragging the mouse pointer it is possible to zoom 

over a specific part of the data (see next figure for example). Once zoomed, it is possible 

to move the series of data to the left or to the right by means of the arrows within the blue 

circles at the bottom of the chart. The small circle placed at the bottom right part of the 

chart allows to undo the zoom of one step each time it is clicked. 

7.4.6.2 Actions > Charts > Raw data 

This chart represents all the data (i.e. the values of the directional variable) independently 

of their directions. An example is shown in the next figure for wind speed. Note that the 

options under Y2 Axis and Y2 Series have no effect for this chart. 
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7.4.6.3 Actions > Charts > Typical day 

This chart represents the typical day for direction and directional variable on the same 

plot. The typical day is obtained by averaging the values for a fixed hour of the day. An 

example is shown in the next figure for wind direction and wind speed. 
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7.4.6.4 Actions > Charts > Data columns 

This chart represents the percent distribution of the values of the directional variable 

within the classes specified by the user. An example is shown in the next figure for wind 

speed. For example, wind speeds between 1 m/s and 2 m/s account for 9.6% of the data, 

while speeds between 2 m/s and 3 m/s account for 26.8% of the data. 

Note that the options under Y2 Axis and Y2 Series have no effect for this chart. 
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7.4.6.5 Actions > Charts > Monthly distribution 

This chart represents the monthly distribution of the values of the directional variable 

through twelve candlesticks, one for each month. An example is shown in the next figure 

for wind speed. Each candlestick represents four values of the distribution, respectively 

from bottom to top: 5th, 25th, 75th and 95th. 

Note that the options under Y2 Axis and Y2 Series have no effect for this chart. 

 

http://www.enviroware.com/


WindRose PRO 3 User's Guide – Version 2015-05-04 – © 2015 Enviroware srl 

90 

 

 

7.4.6.6 Actions > Charts > Weibull 

This chart represents the theoretical Weibull distribution of the directional variable values, 

calculated starting from them, and their actual distribution. An example is shown in the 

next figure for wind speed. Note that the options under Y2 Axis have no effect for this 

chart. On the contrary, the Y Series refers to the actual distribution, and the and Y2 Series 

refers to the theoretical distribution. 
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7.4.6.7 Actions > Charts > Rayleigh 

This chart represents the theoretical Rayleigh distribution of the directional variable 

values, calculated starting from them, and their actual distribution. An example is shown 

in the next figure for wind speed. Note that the options under Y2 Axis have no effect for 

this chart. On the contrary, the Y Series refers to the actual distribution, and the and Y2 

Series refers to the theoretical distribution. 
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7.4.6.8 Actions > Charts > Working events 

This chart represents the distribution of the working events of a specific wind turbine. The 

X axis of the curve represents the number of events between the cut-in and cut-out values 

of the turbine, while the Y axis represents the wind speed. The number of working events 

will increase for low wind speeds, which are more frequent. An example is shown in the 

next figure. Note that the options under Y2 Axis and Y2 Series have no effect for this 

chart. 
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7.4.7 Actions > Turbines 

The Actions > Turbines menu item shows the mask for inserting wind turbine 

properties, and save or load them. The turbines mask can also be loaded by means of 

the button shown in the next figure. 

 

The turbines mask appears as shown in the next figure. The user may insert the main 

features of a turbine and save them in a specific file, with XML format, which will have a 

TRB extension. A TRB file will be loaded, and a specific turbine will be chosen, for 
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evaluating the wind power potential (see 7.3.12 ). Through the TRB files each user will 

be able to create a personalised wind turbines database. 

 

Each turbine can be added or modified by inserting the corresponding values within the 

text boxes and clicking the  button. A single turbine can be deleted by selecting it within 

the grid and clicking the  button, while the  button deletes all the turbines within the 

grid. 

The power curve part of the mask is automatically prepared with wind speeds values as 

soon as the user has specified the cut-in, the rated and the cut-out speeds. The user then 

will insert the power value for each speed. 

The power curve can be graphically represented by means of the  button, as shown 

in the next figure. The chart features can be modified by means of its right panel. Each 

modified option is made visible on the chart only after the  button is clicked. The chart 

can be copied, saved and printed by means of the three buttons placed at the bottom of 

the chart options. 
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Zooming operations are also possible by clicking over the chart and moving the mouse 

pointer. 

7.4.8 Actions > Batch processing 

The Actions > Batch processing menu item allows to produce hourly. Three-hourly 

and monthly wind roses starting from a single input file. The batch processing can be also 

activated by means of the button shown in the next figure. 

 

It is important to note that the batch processing can be activated only when the input 

data are associated to date and time and after a wind rose has been plotted. 

The batch processing mask is shown in the next figure. 
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The user must specify at least a type of plot selecting among monthly, three-hour and 

hourly plots. Depending on how hours are expressed in the input data (i.e. from 00 to 23 

or from 01 to 24), the three-hour plots will be prepared for hours 00-02, 03-05, …, 21-23, 

or from hours 01-03, 04-06, …, 22-24. 

Any date/time filtering applied by the user to the input data will be also applied during the 

batch processing. For example, if the user has excluded from the analysis the months of 

May and June, the wind roses for such months will be not produced. 

The optional Prefix text box allows to add a prefix to the name of the output files written 

in the selected output folder. The output file names in the output folder are (assuming no 

prefix has been specified): 

 MON.format (for monthly files) 

 HH.format (for hourly files) 

 HI-HF.format (for three-hour files) 
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Where MON is the three-letter abbreviation of the month name (e.g. Jan. Feb, …), HH is 

the hour, HI and HF are respectively the initial and final hours of the three-hour period, 

format is one of the possible output format (Jpeg, Png, Bmp). 

All the plots referring to a specific period (monthly, hourly, three-hour) are created using 

the same scale; therefore, for example, all the monthly plots will be comparable. 

The aspect ratio (i.e. ratio between width and height) of the plots is 4:3 or 1:1, depending 

on the user choice to depict on the plot the legend and/or additional information about the 

data (e.g. number of data, average value, etc.). See next figure for an example. If the user 

does not specify to represent the legend over each plot, a Legend.bmp file is produced 

in the output folder (a prefix will precede the name, if specified). 

 

               

It is possible to optimize the number of percentage circles represented on the plot to make 

them clearly visible. If such an option is not selected, some labels may be overlapped. 

A Processing.log file (a prefix will precede the name, if specified) is also created in the 

output folder. Such a file contains additional information about the processing. 

7.5 Help 

The Help menu item allows to carry out the operations described in the following list. 
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7.5.1 Help > Help 

Opens the WindRose PRO User's Guide (this document). 

 

7.5.2 Help > Enter license key 

This menu item opens the Registration mask (see 5 ), which can be used for obtaining 

an evaluation license and for buying the software. 

7.5.3 Help > Contact us 

This menu item allows to send a feedback or report an error via email. Note that the 

message subject is automatically prepared for containing software name, version and 

date (e.g. Feedback for: WindRose PRO 3.1.48.0 (2013-05-31)) 

7.5.4 Help > Web site 

This menu item opens the WindRose PRO web page on the Enviroware's internet site. 

7.5.5 Help > Check for updates 

This menu item checks for software updates connecting to the Enviroware internet site. 

7.5.6 Help > About 

This menu item opens the About mask which contains information about the software 

version and date. 
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9. CONTACTS 

If you need additional information about WindRose PRO, please contact us: 

 

Enviroware srl 

via Dante 142 

20863 Concorezzo (MB) 

Italy 

 

Email: info@enviroware.com 

URL: http://www.enviroware.com 
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